PSD2 degraded performance

Incident Report for Experian

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 16:30 CEST

Identified

Due to issues at BEC, some customers may experience issues when attempting to give PSD2 consent to BEC banks. BEC is investigating the issue. A list of BEC customers can be found here: https://www.bec.dk/en/becs-customers/

https://status.subaio.com/incidents/p9b4y6yhvkcm
Posted Aug 31, 2026 - 11:00 CEST
This incident affected: Credit Board ([Denmark] PSD2).