Case report not functional in Credit Board UI

Incident Report for Experian

Resolved

A fix has been deployed to production. Case reports should now be showing correctly again.
Posted Apr 22, 2026 - 13:02 UTC

Identified

The case report in the Credit Board UI is currently not functional after last night's release. We are working on a solution.
Posted Apr 22, 2026 - 08:42 UTC
This incident affected: Credit Board (Credit Board).